在线
客服
在线
QQ
电话
咨询
400-700-1020
购买 公众号 返回
顶部

Loding the player....

本视频来由慧都学院提供   查看原视频>>

解决Linux Internal Web浏览器的兼容性问题

MyEclipse特性与Linux内部web浏览器的兼容性问题

Eclipse 3.3现在支持所有平台上的Mozilla浏览器(对Mozilla的迟滞无处不在),对于无处不在的Mozilla更多信息:详见bug#7923。对于MyEclipse的Linux用户来说,这就意味着附带的MyEclipse 6.0嵌入的Mozilla浏览器核心可以作为Eclipse平台的核心浏览器,随着附带的MyEclipse 6.0嵌入的Mozilla浏览器核心需要MyEclipse的特性如下:

需要嵌入MyEclipse的Mozilla浏览器核心的运行特点:

  • AJAX Web浏览器
  • JavaScript调试器

在过去,MyEclipse的Linux用户必须通过修改环境设置来使嵌入的Mozilla浏览器核心能够正常的工作。然而随着MyEclipse 6.0的出现,在大多数情况下不需要额外的配置就能正常运行。但是在少数的情况下,Mozilla浏览器核心可能无法操作,仍然需要额外的配置。

何时额外配置是必要的

当你第一次使用AJAX Web浏览器或JavaScript调试器时,则不需要进一步配置。但是,如果你看到下面的对话框:

如果你看到下面这个警告信息,请阅读下一节步骤来修改环境以保证MyEclipse功能的正常运行。

启用AJAX Web浏览器或JavaScript调试器

本节介绍配置环境,以确保AJAX Web浏览器和JavaScript调试器始终是正常运行:

  1. 关闭MyEclipse。
  2. 在配置环境变量之前,Eclipse启动创建一个shell脚本。
  3. 设置MOZILLA_FIVE_HOME环境变量的值""。

    startup-script.sh
    export MOZILLA_FIVE_HOME=””
    ./eclipse (other args)

    或者

    只是将 'export MOZILLA_FIVE_HOME=""'字符串添加到你通常使用的Linux前面:

    Shell command
    $shell prompt$ MOZILLA_FIVE_HOME=”” ./eclipse (other args)
  1.  使用这种新的启动脚本或新的shell命令来启动MyEclipse。

如果执行这些步骤仍然有问题,请到我们的MyEclipse论坛提问,我们将帮助你解决特定问题。